Error code 1603 when installing Office 2010 on Windows XP

From time to time less technical friends ask me to reinstall their Windows and applications. Usually this takes a couple of hours, but the last time I did this things went completely wrong with Microsoft Office 2010 Pro. The OS was a Windows XP SP3, all security updates with MSE as antivirus solution. After starting the setup the installer failed with a very helpful message “something went wrong”. Thanks a lot Microsoft!

Tried with Run as Administrator. Same thing, failed within seconds after I’ve clicked install. I quickly begin searching the net for Office install issues. Found that the log for the installer is located in the temp directory. To get there simply go to My Computer and in the address bar type %temp%. Look for files called setup*. After reading through the log files found that I had an ErrorCode 1603. Nice thing, very helpful. Search again for 1603, read countless threads on Microsoft site. Tons of bullshits, unrelated answers, you know the usual Microsoft support experience: you did something wrong, uninstall and install again and hope it will magically work this time. It didn’t work! I tried setting the security permissions on files to allow SYSTEM to modify anything on C:, ran as Administrator, got another copy of Office 2010, installed Windows Search 4.0.

The solution I’ve found from a friend of mine:
1) Delete everything in %temp%
2) Go to %appdata% and delete everything from Microsoft/Office
3) Delete everything from C:\Program Files\Microsoft Office
4) C:\Documents and Settings\All Users\Application Data delete everything related to Office
5) regedit and delete the keys for Office from HKEY_LOCAL_MACHINE\Software and HKEY_CURRENT_USER\Software
6) Finally start the installer as Administrator

Hopefully it will work for you, it was a very frustrating experience for me!

Fred

Well! Thank you very much with post ;

I have been fighting for hours with this failure while installing Office 2010 SP2 on a W2K3R2SP2 server. Damned. Had this same error 1603 logged into the logfile (hopefully I had a look into the event log to see that a log was created). Been reading tons on BS on various forums, and finally landed on this page : your method saved my day, Office 2010 SP2 just installed successfully!

So many thanks!
Fred

Your email address will not be published. Required fields are marked *